summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/libraries/python-trinity/debian/rules
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-08-27 21:17:52 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-08-27 21:17:52 +0200
commit1af57210e2e55d40eb39a274fcf48779c6b9e7d5 (patch)
tree55c22bbd35462f1c940b24614af05ea07bcd7f35 /ubuntu/maverick/libraries/python-trinity/debian/rules
parentaf8c5ead9ac4c1ece3408b74224e5e273b6994ce (diff)
parent2d0d0ba99b507cab093962cb910ddc7dd4755c94 (diff)
downloadtde-packaging-1af57210e2e55d40eb39a274fcf48779c6b9e7d5.tar.gz
tde-packaging-1af57210e2e55d40eb39a274fcf48779c6b9e7d5.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/libraries/python-trinity/debian/rules')
-rwxr-xr-xubuntu/maverick/libraries/python-trinity/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/ubuntu/maverick/libraries/python-trinity/debian/rules b/ubuntu/maverick/libraries/python-trinity/debian/rules
index 67af8c2d8..d4dac70f3 100755
--- a/ubuntu/maverick/libraries/python-trinity/debian/rules
+++ b/ubuntu/maverick/libraries/python-trinity/debian/rules
@@ -31,6 +31,9 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
+DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
SPLIT=20
@@ -149,7 +152,7 @@ ifeq (,$(findstring -i, $(DH_OPTIONS)))
endif
dh_compress -X.py -X.ui -X.dtd
dh_fixperms
- DH_PYCENTRAL=nomove dh_pycentral
+ ${DH_PYTHON2}
dh_installdeb
dh_shlibdeps -l /opt/trinity/lib
dh_gencontrol