summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/tdevelop/debian/rules
diff options
context:
space:
mode:
authorCalvin Morrison <mutantturke@gmail.com>2011-11-13 19:27:09 -0500
committerCalvin Morrison <mutantturke@gmail.com>2011-11-13 19:27:09 -0500
commitb04ad86203e19f0e89e971fefc3f40b380cbe7b2 (patch)
tree639782b440de136501ae6ee50d8d54450765346f /ubuntu/maverick/tdevelop/debian/rules
parent7123ebd91f9851d8a0479d043508ec5885e24f91 (diff)
parent70daaabb4fd5f3b559f5ef489377c9fe93a47f0d (diff)
downloadtde-packaging-b04ad86203e19f0e89e971fefc3f40b380cbe7b2.tar.gz
tde-packaging-b04ad86203e19f0e89e971fefc3f40b380cbe7b2.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/tdevelop/debian/rules')
-rwxr-xr-xubuntu/maverick/tdevelop/debian/rules59
1 files changed, 59 insertions, 0 deletions
diff --git a/ubuntu/maverick/tdevelop/debian/rules b/ubuntu/maverick/tdevelop/debian/rules
new file mode 100755
index 000000000..f5bce32b3
--- /dev/null
+++ b/ubuntu/maverick/tdevelop/debian/rules
@@ -0,0 +1,59 @@
+#!/usr/bin/make -f
+
+# work around debian/cdbs/uploaders.mk
+makebuilddir::
+ [ -f debian/control.tmp ] || cp debian/control debian/control.tmp
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+PACKAGES_WITH_LIBS := tdevelop-trinity
+
+DEB_KDE_ENABLE_FINAL :=
+DEB_INSTALL_DOCS_tdevelop = AUTHORS
+DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/tmp
+DEB_CONFIGURE_EXTRA_FLAGS := \
+ --disable-debug \
+ --enable-docbase \
+ --enable-scripting \
+ --enable-ada \
+ --enable-bash \
+ --enable-cpp \
+ --enable-fortran \
+ --enable-haskell \
+ --enable-java \
+ --enable-pascal \
+ --enable-perl \
+ --enable-php \
+ --enable-python \
+ --enable-ruby \
+ --enable-sql \
+ --enable-antproject \
+ --enable-autoproject \
+ --enable-customproject \
+ --enable-genericproject \
+ --enable-scriptproject \
+ --enable-trollproject \
+ --enable-cvs \
+ --enable-vba \
+ --enable-subversion \
+ --with-pic \
+ --with-tdelibsdoxy-dir=/opt/trinity/share/doc/kde/HTML/en/tdelibs-apidocs \
+ --with-pythondir=/usr \
+ --with-qtdoc-dir=/usr/share/qt3/doc/html \
+ --prefix=/opt/trinity \
+ --with-extra-libs=/opt/trinity/lib
+
+binary-install/tdevelop-trinity::
+ mkdir -p debian/tdevelop-trinity/opt/trinity/share/pixmaps
+ cp debian/tdevelop.xpm debian/tdevelop-trinity/opt/trinity/share/pixmaps
+