summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/kscope/debian/rules
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-10-09 21:25:19 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-10-09 21:25:19 +0200
commitbd0ff7568ce64694ae7b1a180c1cc3654f4e60a9 (patch)
tree6074483ea9db86f4e118bd3ee987b9f78f63f143 /ubuntu/precise/applications/kscope/debian/rules
parent1b75a8a69eb58af5ed985debdf5020df147d1df5 (diff)
parent26882ca86584e3ceecc0104ddfbf4f9d118c8e04 (diff)
downloadtde-packaging-bd0ff7568ce64694ae7b1a180c1cc3654f4e60a9.tar.gz
tde-packaging-bd0ff7568ce64694ae7b1a180c1cc3654f4e60a9.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/precise/applications/kscope/debian/rules')
-rwxr-xr-xubuntu/precise/applications/kscope/debian/rules40
1 files changed, 40 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/kscope/debian/rules b/ubuntu/precise/applications/kscope/debian/rules
new file mode 100755
index 000000000..65883a481
--- /dev/null
+++ b/ubuntu/precise/applications/kscope/debian/rules
@@ -0,0 +1,40 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+build/kscope-trinity::
+ /usr/bin/docbook2x-man debian/kscope.xml
+
+binary-install/kscope-trinity::
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+
+clean::
+ rm -f kscope.1
+ rm -f debian/stamp-bootstrap