summaryrefslogtreecommitdiffstats
path: root/ubuntu/raring/applications/kbiff/debian/rules
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-07-05 20:14:37 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-07-05 20:14:37 +0200
commita3e930f3a1acd0f15ea454d98ee69bf0fa5090ad (patch)
tree7e5128124507402ac26cfadde03332a149c8f44f /ubuntu/raring/applications/kbiff/debian/rules
parentcdd1dbbf3c55439d343003ed268165716f40b2af (diff)
parent87dc0649077ea66ac593b3397b84c4144bbe12f8 (diff)
downloadtde-packaging-a3e930f3a1acd0f15ea454d98ee69bf0fa5090ad.tar.gz
tde-packaging-a3e930f3a1acd0f15ea454d98ee69bf0fa5090ad.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/raring/applications/kbiff/debian/rules')
-rwxr-xr-xubuntu/raring/applications/kbiff/debian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/ubuntu/raring/applications/kbiff/debian/rules b/ubuntu/raring/applications/kbiff/debian/rules
new file mode 100755
index 000000000..39a274279
--- /dev/null
+++ b/ubuntu/raring/applications/kbiff/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap