summaryrefslogtreecommitdiffstats
path: root/ubuntu/raring/applications/kerry/debian/patches
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-28 14:13:18 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-28 14:13:18 -0500
commit4bc22e8b188aa26df8b1a23c39bb0f3c5b05b8b6 (patch)
treec6f53decaabed9678523a8bbd6a1000a9f3bf78f /ubuntu/raring/applications/kerry/debian/patches
parent211d261d7778de1d9a773e7ec43a4e97b4bd7e57 (diff)
downloadtde-packaging-4bc22e8b188aa26df8b1a23c39bb0f3c5b05b8b6.tar.gz
tde-packaging-4bc22e8b188aa26df8b1a23c39bb0f3c5b05b8b6.zip
Split raring packaging into new directory due to defoma changes
Diffstat (limited to 'ubuntu/raring/applications/kerry/debian/patches')
-rw-r--r--ubuntu/raring/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch12
-rw-r--r--ubuntu/raring/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch19
-rw-r--r--ubuntu/raring/applications/kerry/debian/patches/kubuntu_05_shortkey.patch13
3 files changed, 44 insertions, 0 deletions
diff --git a/ubuntu/raring/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch b/ubuntu/raring/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
new file mode 100644
index 000000000..811069db9
--- /dev/null
+++ b/ubuntu/raring/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
@@ -0,0 +1,12 @@
+diff -Nur kerry-0.2.1/kerry/src/Makefile.am kerry-0.2.1.new/kerry/src/Makefile.am
+--- kerry-0.2.1/kerry/src/Makefile.am 2006-12-05 18:28:31.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/Makefile.am 2006-12-05 18:28:53.000000000 +0100
+@@ -31,7 +31,7 @@
+ kerry_la_LIBADD = -lkio -lkonq $(LIB_TDEUI) $(LIBBEAGLE_LIBADD) $(GLIB_LIBADD) $(LIB_TDEABC) -lDCOP $(LIB_QT) $(LIB_TDECORE)
+
+ autostartdir = $(datadir)/autostart
+-autostart_DATA = kerry.autostart.desktop beagled.desktop
++autostart_DATA = kerry.autostart.desktop
+
+ shutdowndir = $(prefix)/bin
+ shutdown_SCRIPTS = beagled-shutdown
diff --git a/ubuntu/raring/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch b/ubuntu/raring/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
new file mode 100644
index 000000000..896193aba
--- /dev/null
+++ b/ubuntu/raring/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
@@ -0,0 +1,19 @@
+diff -Nur -x '*.orig' -x '*~' kerry-0.2.1/kerry/src/kerry.desktop kerry-0.2.1.new/kerry/src/kerry.desktop
+--- kerry-0.2.1/kerry/src/kerry.desktop 2006-12-04 14:35:38.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/kerry.desktop 2008-04-08 22:55:31.000000000 +0200
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ X-SuSE-translate=true
+-Encoding=UTF-8
+ Name=Kerry Beagle
+ GenericName=Desktop Search
+ GenericName[ar]=بحث على سطح المكتب
+@@ -25,7 +24,7 @@
+ Exec=kerry --show-searchdialog
+ Icon=kerry
+ Type=Application
+-Categories=Qt;TDE;Application;Core;Utility;Filesystem;
++Categories=Qt;TDE;Application;Utility;Filesystem;
+ Terminal=false
+ X-DCOP-ServiceType=Unique
+ X-TDE-StartupNotify=false
diff --git a/ubuntu/raring/applications/kerry/debian/patches/kubuntu_05_shortkey.patch b/ubuntu/raring/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
new file mode 100644
index 000000000..c4a705c68
--- /dev/null
+++ b/ubuntu/raring/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
@@ -0,0 +1,13 @@
+diff -Nur kerry-0.2.1/kerry/src/kerryapp.cpp kerry-0.2.1.new/kerry/src/kerryapp.cpp
+--- kerry-0.2.1/kerry/src/kerryapp.cpp
++++ kerry-0.2.1.new/kerry/src/kerryapp.cpp
+@@ -122,8 +122,7 @@
+ globalKeys = new TDEGlobalAccel(TQT_TQOBJECT(this));
+ globalKeys->insert( "Program:kerry", i18n("Kerry Beagle Search") );
+
+- TDEShortcut showDialogShortcut = TDEShortcut(ALT+Key_Space);
+- showDialogShortcut.append( KKey( Key_F12 ) );
++ TDEShortcut showDialogShortcut = TDEShortcut(CTRL+SHIFT+Key_Space);
+ globalKeys->insert( "Show Kerry Dialog", i18n("Show Search Dialog"), TQString(), showDialogShortcut, showDialogShortcut, TQT_TQOBJECT(hitListWindow), TQT_SLOT(showSearchDialog()) );
+ globalKeys->insert( "Search Primary Selection with Kerry", i18n("Search Primary Selection"), TQString(), CTRL+ALT+Key_Space, CTRL+ALT+Key_Space, TQT_TQOBJECT(this), TQT_SLOT(searchPrimarySelection()) );
+ configChanged();