summaryrefslogtreecommitdiffstats
path: root/ubuntu/raring/applications/tdepowersave/debian/cdbs
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-10-09 21:25:19 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-10-09 21:25:19 +0200
commitbd0ff7568ce64694ae7b1a180c1cc3654f4e60a9 (patch)
tree6074483ea9db86f4e118bd3ee987b9f78f63f143 /ubuntu/raring/applications/tdepowersave/debian/cdbs
parent1b75a8a69eb58af5ed985debdf5020df147d1df5 (diff)
parent26882ca86584e3ceecc0104ddfbf4f9d118c8e04 (diff)
downloadtde-packaging-bd0ff7568ce64694ae7b1a180c1cc3654f4e60a9.tar.gz
tde-packaging-bd0ff7568ce64694ae7b1a180c1cc3654f4e60a9.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/raring/applications/tdepowersave/debian/cdbs')
-rw-r--r--ubuntu/raring/applications/tdepowersave/debian/cdbs/debian-qt-kde.mk4
-rw-r--r--ubuntu/raring/applications/tdepowersave/debian/cdbs/kde.mk4
2 files changed, 7 insertions, 1 deletions
diff --git a/ubuntu/raring/applications/tdepowersave/debian/cdbs/debian-qt-kde.mk b/ubuntu/raring/applications/tdepowersave/debian/cdbs/debian-qt-kde.mk
index c807eed8c..33a932634 100644
--- a/ubuntu/raring/applications/tdepowersave/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/raring/applications/tdepowersave/debian/cdbs/debian-qt-kde.mk
@@ -10,9 +10,11 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -98,6 +100,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -106,6 +109,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/ubuntu/raring/applications/tdepowersave/debian/cdbs/kde.mk b/ubuntu/raring/applications/tdepowersave/debian/cdbs/kde.mk
index 765560c89..023886fc8 100644
--- a/ubuntu/raring/applications/tdepowersave/debian/cdbs/kde.mk
+++ b/ubuntu/raring/applications/tdepowersave/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
+ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%: