summaryrefslogtreecommitdiffstats
path: root/ubuntu/raring/tdenetwork/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2014-04-17 13:53:27 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2014-04-17 13:53:27 +0900
commit7ceb46211ddfdbfd07b79e9cd2077ed0605ef47e (patch)
tree6a309da61ff8fad680a38dd405e7066646262cfa /ubuntu/raring/tdenetwork/debian/rules
parente43a1170040313d3384f0eefdf7a071059b9c2a9 (diff)
downloadtde-packaging-7ceb46211ddfdbfd07b79e9cd2077ed0605ef47e.tar.gz
tde-packaging-7ceb46211ddfdbfd07b79e9cd2077ed0605ef47e.zip
Removed Ubuntu/raring folder
Diffstat (limited to 'ubuntu/raring/tdenetwork/debian/rules')
-rwxr-xr-xubuntu/raring/tdenetwork/debian/rules64
1 files changed, 0 insertions, 64 deletions
diff --git a/ubuntu/raring/tdenetwork/debian/rules b/ubuntu/raring/tdenetwork/debian/rules
deleted file mode 100755
index 51643631e..000000000
--- a/ubuntu/raring/tdenetwork/debian/rules
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/usr/bin/make -f
-
-DEB_HOST_ARCH_OS=$(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_HOST_ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
-
-ifeq ($(DEB_HOST_ARCH),s390)
-DONT_BUILD+= kwifimanager
-endif
-ifneq ($(DEB_HOST_ARCH_OS),linux)
-DONT_BUILD+= kwifimanager tdednssd
-endif
-export DH_OPTIONS
-
-# include debian/cdbs/buildvars.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-qt-kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ARTS="ON" \
- -DWITH_SLP="ON" \
- -DBUILD_KOPETE_PROTOCOL_ALL="ON" \
- -DBUILD_KOPETE_PLUGIN_ALL="ON"
-
-DEB_DH_STRIP_ARGS := --dbg-package=tdenetwork-trinity-dbg
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-PACKAGES_WITH_LIBS := librss1-trinity kopete-trinity ksirc-trinity kwifimanager-trinity
-
-#shlibs_ver = 4:3.5.0-1
-#$(foreach p,$(PACKAGES_WITH_LIBS),$(eval DEB_DH_MAKESHLIBS_ARGS_$(p) := -V'$(p) (>= $(shlibs_ver))'))
-
-DEB_FIXPERMS_EXCLUDE := opt/trinity/bin/kppp opt/trinity/bin/kppplogview \
- opt/trinity/etc/ppp/peers/kppp-options
-
-DOC_HTML_PRUNE := kcontrol
-
-binary-install/kppp-trinity::
- chown root:dip debian/kppp-trinity/opt/trinity/bin/kppp*
- chown root:dip debian/kppp-trinity/opt/trinity/etc/ppp/peers/kppp-options
- chmod 4754 debian/kppp-trinity/opt/trinity/bin/kppp
- chmod 0754 debian/kppp-trinity/opt/trinity/bin/kppplogview
- chmod 0640 debian/kppp-trinity/opt/trinity/etc/ppp/peers/kppp-options