summaryrefslogtreecommitdiffstats
path: root/redhat/applications/misc/kcmldapcontroller/kcmldapcontroller.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/misc/kcmldapcontroller/kcmldapcontroller.spec')
-rw-r--r--redhat/applications/misc/kcmldapcontroller/kcmldapcontroller.spec20
1 files changed, 18 insertions, 2 deletions
diff --git a/redhat/applications/misc/kcmldapcontroller/kcmldapcontroller.spec b/redhat/applications/misc/kcmldapcontroller/kcmldapcontroller.spec
index 977ff2146..cacb6565a 100644
--- a/redhat/applications/misc/kcmldapcontroller/kcmldapcontroller.spec
+++ b/redhat/applications/misc/kcmldapcontroller/kcmldapcontroller.spec
@@ -79,8 +79,12 @@ BuildRequires: brp-check-trinity
# OPENLDAP support
%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
+%if 0%{?mdkver}
+BuildRequires: lib64ldap-devel
+%else
BuildRequires: openldap-devel
%endif
+%endif
%if 0%{?mgaversion} >= 6
BuildRequires: openldap-servers-devel
%endif
@@ -105,8 +109,12 @@ BuildRequires: libheimdal-devel
# UDEV support
%if 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion} || 0%{?suse_version} || 0%{?rhel} >= 6
%define with_tdehwlib 1
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}udev-devel
+%else
BuildRequires: libudev-devel
%endif
+%endif
# LIBCOM_ERR support
%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 6
@@ -117,13 +125,21 @@ BuildRequires: %{_lib}ext2fs-devel
%endif
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# IDN support
BuildRequires: libidn-devel
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
Requires: trinity-kcontrol-ldap-controller = %{?epoch:%{epoch}:}%{version}-%{release}
@@ -146,7 +162,7 @@ This is a TDE control center module to manage users, groups, and machines in Ker
%defattr(-,root,root,-)
%doc AUTHORS COPYING
%{tde_bindir}/primaryrccertupdater
-%if 0%{?fedora} || 0%{?mgaversion} || 0%{?rhel} >= 7
+%if 0%{?fedora} || 0%{?mdkver} || 0%{?mgaversion} || 0%{?rhel} >= 7
%{tde_libdir}/slapi-acl-manager.la
%{tde_libdir}/slapi-acl-manager.so
%endif
@@ -181,7 +197,7 @@ unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi