summaryrefslogtreecommitdiffstats
path: root/redhat/applications/multimedia/amarok/amarok.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/multimedia/amarok/amarok.spec')
-rw-r--r--redhat/applications/multimedia/amarok/amarok.spec46
1 files changed, 39 insertions, 7 deletions
diff --git a/redhat/applications/multimedia/amarok/amarok.spec b/redhat/applications/multimedia/amarok/amarok.spec
index b15e28632..392177acf 100644
--- a/redhat/applications/multimedia/amarok/amarok.spec
+++ b/redhat/applications/multimedia/amarok/amarok.spec
@@ -72,7 +72,11 @@ BuildRequires: pkgconfig
BuildRequires: gettext
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# SUSE desktop files utility
%if 0%{?suse_version}
@@ -84,8 +88,12 @@ BuildRequires: update-desktop-files
BuildRequires: brp-check-trinity
%endif
-# ALSA support
-BuildRequires: alsa-lib-devel
+# ALSA supportl
+%if 0%{?mdkver}
+BuildRequires: %{_lib}asound-devel
+%else
+BuildRequires: alsa-lib-devel
+%endif
# ESOUND support
#BuildRequires: esound-devel
@@ -106,9 +114,15 @@ BuildRequires: libusb-compat-0.1-devel
BuildRequires: libusb-devel
%endif
BuildRequires: mysql-devel
-BuildRequires: SDL-devel
BuildRequires: taglib-devel
+# SDL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}SDL-devel
+%else
+BuildRequires: SDL-devel
+%endif
+
# SQLITE3 support
%if 0%{?mgaversion}
BuildRequires: sqlite3-devel
@@ -159,13 +173,13 @@ BuildRequires: trinity-dbus-tqt-devel >= 1:0.63
%if 0%{?pclinuxos} == 0
%if 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
%define with_ifp 1
-BuildRequires: libifp-devel
+BuildRequires: %{_lib}ifp-devel
%endif
%endif
# KARMA support
%if 0%{?mgaversion} || 0%{?mdkversion}
-%if 0%{?pclinuxos} == 0
+%if 0%{?pclinuxos} == 0 && 0%{?mdkver} == 0
%define with_karma 1
BuildRequires: libkarma-devel
BuildRequires: karma-sharp
@@ -181,20 +195,32 @@ BuildRequires: libgpod-devel >= 0.4.2
# MTP players
%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion} || 0%{?suse_version}
%define with_mtp 1
+%if 0%{?mdkver}
+BuildRequires: %{_lib}mtp-devel
+%else
BuildRequires: libmtp-devel
%endif
+%endif
# Creative Nomad Jukebox
%if 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?suse_version} >= 1220
%define with_njb 1
-BuildRequires: libnjb-devel
+%if 0%{?mdkver}
+BuildRequires: %{_lib}njb-devel
+%else
+BuildRequires: libmtp-devel
+%endif
%endif
# VISUAL support
%if 0%{?rhel} >= 4 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion} || 0%{?suse_version}
%define with_libvisual 1
+%if 0%{?mdkver}
+BuildRequires: %{_lib}visual-devel
+%else
BuildRequires: libvisual-devel
%endif
+%endif
# MUSICBRAINZ support
%if 0%{?mgaversion} || 0%{?fedora} || 0%{?suse_version}
@@ -242,8 +268,12 @@ BuildRequires: xine-lib-devel
%endif
%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?pclinuxos}
%define with_xine 1
+%if 0%{?mdkver}
+BuildRequires: %{_lib}xine-devel
+%else
BuildRequires: %{_lib}xine1.2-devel
%endif
+%endif
%if 0%{?sle_version} && 0%{?sle_version} <= 150000
%define with_xine 1
BuildRequires: libxine-devel
@@ -262,9 +292,11 @@ BuildRequires: trinity-akode-devel
# MP4V2 support
%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?suse_version}
+%if 0%{?mdkver} == 0
%define with_mp4v2 1
BuildRequires: libmp4v2-devel
%endif
+%endif
# ruby
BuildRequires: ruby
@@ -481,7 +513,7 @@ if [ -d /usr/X11R6 ]; then
export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
fi
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi