summaryrefslogtreecommitdiffstats
path: root/redhat/applications/office/tellico/tellico.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/office/tellico/tellico.spec')
-rw-r--r--redhat/applications/office/tellico/tellico.spec24
1 files changed, 21 insertions, 3 deletions
diff --git a/redhat/applications/office/tellico/tellico.spec b/redhat/applications/office/tellico/tellico.spec
index ddc88347b..e51a25226 100644
--- a/redhat/applications/office/tellico/tellico.spec
+++ b/redhat/applications/office/tellico/tellico.spec
@@ -110,7 +110,12 @@ BuildRequires: %{_lib}yaz-devel
BuildRequires: libxml2-devel
# XSLT support
-BuildRequires: libxslt-devel
+%if 0%{?mdkver}
+BuildRequires: %{_lib}xslt-devel
+%else
+BuildRequires: libxslt-devel
+%endif
+
%if 0%{?rhel} == 4
# a bogus dep in libexslt.la file from EL-4 (WONTFIX bug http://bugzilla.redhat.com/142241)
BuildRequires: libgcrypt-devel
@@ -145,13 +150,26 @@ BuildRequires: gamin-devel
%endif
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# ATTR support
-BuildRequires: libattr-devel
+%if 0%{?mgaversion} || 0%{?mdkversion}
+%define libattr_devel %{_lib}attr-devel
+%else
+%define libattr_devel libattr-devel
+%endif
+BuildRequires: %{libattr_devel}
# PYTHON support
%global python python3
@@ -301,7 +319,7 @@ unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi