summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/arts/trinity-arts-3.5.13.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/arts/trinity-arts-3.5.13.spec')
-rwxr-xr-xredhat/dependencies/arts/trinity-arts-3.5.13.spec117
1 files changed, 66 insertions, 51 deletions
diff --git a/redhat/dependencies/arts/trinity-arts-3.5.13.spec b/redhat/dependencies/arts/trinity-arts-3.5.13.spec
index a4c3fd276..af9fef33a 100755
--- a/redhat/dependencies/arts/trinity-arts-3.5.13.spec
+++ b/redhat/dependencies/arts/trinity-arts-3.5.13.spec
@@ -33,9 +33,7 @@ Patch0: arts-3.5.13-enable_oss.patch
# TDE 3.5.13: Re-enable lost JACK support
Patch1: arts-3.5.13-enable_jack.patch
-Patch2: arts-3.5.13-add_pulseaudio_support.patch
-
-BuildRequires: tqtinterface-devel
+BuildRequires: tqtinterface-devel >= %{version}
BuildRequires: audiofile-devel
BuildRequires: alsa-lib-devel
BuildRequires: glib2-devel
@@ -46,10 +44,15 @@ BuildRequires: esound-devel
%if 0%{?mgaversion} || 0%{?mdkversion}
BuildRequires: %{_lib}jack-devel
BuildRequires: %{_lib}ltdl-devel
-%else
+%endif
+%if 0%{?rhel} >= 5
BuildRequires: jack-audio-connection-kit-devel
BuildRequires: libtool-ltdl-devel
%endif
+%if 0%{?suse_version}
+BuildRequires: libjack-devel
+BuildRequires: libltdl-devel
+%endif
# TDE 3.5.13 specific building variables
BuildRequires: cmake >= 2.8
@@ -73,29 +76,79 @@ By connecting all those small modules together, you can perform complex
tasks like simulating a mixer, generating an instrument or things like
playing a wave file with some effects.
+%files
+%defattr(-,root,root,-)
+%doc COPYING.LIB
+%dir %{tde_libdir}/mcop
+%dir %{tde_libdir}/mcop/Arts
+%{tde_libdir}/mcop/Arts/*
+%{tde_libdir}/mcop/*.mcopclass
+%{tde_libdir}/mcop/*.mcoptype
+%{tde_libdir}/lib*.so.*
+%{tde_bindir}/artscat
+%{tde_bindir}/artsd
+%{tde_bindir}/artsdsp
+%{tde_bindir}/artsplay
+%{tde_bindir}/artsrec
+%{tde_bindir}/artsshell
+%{tde_bindir}/artswrapper
+# The '.la' files are runtime, not devel !
+%{tde_libdir}/lib*.la
+
+%post
+/sbin/ldconfig || :
+
+%postun
+/sbin/ldconfig || :
+
+##########
%package devel
Group: Development/Libraries
Summary: %{name} - Development files
Requires: %{name} = %{version}-%{release}
-%if "%{?_prefix}" == "/usr"
+%if "%{?tde_prefix}" == "/usr"
Obsoletes: arts-devel
%endif
%description devel
Development files for %{name}
+%files devel
+%defattr(-,root,root,-)
+%{tde_bindir}/mcopidl
+%{tde_tdeincludedir}/arts/
+%{tde_includedir}/artsc/
+%{tde_bindir}/artsc-config
+%{tde_libdir}/lib*.so
+%{tde_libdir}/pkgconfig/*.pc
+%{tde_libdir}/*.a
+
+%post devel
+/sbin/ldconfig || :
+
+%postun devel
+/sbin/ldconfig || :
+
+##########
+
+%if 0%{?suse_version}
+%debug_package
+%endif
+
+##########
+
+
%prep
%setup -q -n dependencies/arts
%patch0 -p1
%patch1 -p1
-%patch2 -p1 -b .pulse
%build
-unset QTDIR || : ; . /etc/profile.d/qt.sh
+unset QTDIR || : ; . /etc/profile.d/qt3.sh
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-%if 0%{?rhel} || 0%{?fedora}
+%if 0%{?rhel} || 0%{?fedora} || 0%{?suse_version}
%__mkdir_p build
cd build
%endif
@@ -103,7 +156,7 @@ cd build
%cmake \
-DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
-DBIN_INSTALL_DIR=%{tde_bindir} \
- -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir}/arts \
+ -DINCLUDE_INSTALL_DIR=%{tde_includedir}/arts \
-DLIB_INSTALL_DIR=%{tde_libdir} \
-DPKGCONFIG_INSTALL_DIR=%{tde_libdir}/pkgconfig \
-DWITH_ALSA=ON \
@@ -111,7 +164,11 @@ cd build
-DWITH_VORBIS=ON \
-DWITH_MAD=OFF \
-DWITH_ESOUND=ON \
+%if 0%{?rhel} == 4
+ -DWITH_JACK=OFF \
+%else
-DWITH_JACK=ON \
+%endif
-DCMAKE_SKIP_RPATH="OFF" \
..
@@ -125,48 +182,6 @@ cd build
%clean
%__rm -rf %{?buildroot}
-%post
-/sbin/ldconfig || :
-
-%postun
-/sbin/ldconfig || :
-
-%post devel
-/sbin/ldconfig || :
-
-%postun devel
-/sbin/ldconfig || :
-
-
-%files
-%defattr(-,root,root,-)
-%doc COPYING.LIB
-%dir %{tde_libdir}/mcop
-%dir %{tde_libdir}/mcop/Arts
-%{tde_libdir}/mcop/Arts/*
-%{tde_libdir}/mcop/*.mcopclass
-%{tde_libdir}/mcop/*.mcoptype
-%{tde_libdir}/lib*.so.*
-%{tde_bindir}/artscat
-%{tde_bindir}/artsd
-%{tde_bindir}/artsdsp
-%{tde_bindir}/artsplay
-%{tde_bindir}/artsrec
-%{tde_bindir}/artsshell
-%{tde_bindir}/artswrapper
-# The '.la' files are runtime, not devel !
-%{tde_libdir}/lib*.la
-
-%files devel
-%defattr(-,root,root,-)
-%{tde_bindir}/mcopidl
-%{tde_tdeincludedir}/arts/
-%{tde_includedir}/artsc/
-%{tde_bindir}/artsc-config
-%{tde_libdir}/lib*.so
-%{tde_libdir}/pkgconfig/*.pc
-%{tde_libdir}/*.a
-
%changelog
* Fri Dec 16 2011 Francois Andriot <francois.andriot@free.fr> - 3.5.13-4