summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kbfx/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/kbfx/debian')
-rwxr-xr-xubuntu/maverick/applications/kbfx/debian/rules5
-rw-r--r--ubuntu/maverick/applications/kbfx/debian/source/options4
2 files changed, 6 insertions, 3 deletions
diff --git a/ubuntu/maverick/applications/kbfx/debian/rules b/ubuntu/maverick/applications/kbfx/debian/rules
index 2bffe9b78..97b64d997 100755
--- a/ubuntu/maverick/applications/kbfx/debian/rules
+++ b/ubuntu/maverick/applications/kbfx/debian/rules
@@ -24,6 +24,9 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_CMAKE_EXTRA_FLAGS = -DLIB_SUFFIX="" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" -DCMAKE_INSTALL_PREFIX="/opt/trinity/" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
get-orig-source:
@@dh_testdir
@@[ -d ../tarballs/. ]
@@ -74,6 +77,6 @@ binary-arch: build
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
diff --git a/ubuntu/maverick/applications/kbfx/debian/source/options b/ubuntu/maverick/applications/kbfx/debian/source/options
index 9d7c8e036..72f1f5450 100644
--- a/ubuntu/maverick/applications/kbfx/debian/source/options
+++ b/ubuntu/maverick/applications/kbfx/debian/source/options
@@ -1,5 +1,5 @@
-# Use bzip2 instead of gzip
-compression = "bzip2"
+# Use xz instead of gzip
+compression = "xz"
compression-level = 9
# Don't run differences