From cf7518355a02b3655a962eb6ef50e246ec2ae21d Mon Sep 17 00:00:00 2001
From: Michele Calgaro <michele.calgaro@yahoo.it>
Date: Mon, 17 Sep 2018 21:44:56 +0900
Subject: DEB: Add multi-arch support to tqca-tls.

Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
---
 debian/lenny/dependencies/tqca-tls/debian/control            | 1 +
 debian/lenny/dependencies/tqca-tls/debian/rules              | 9 ++++++++-
 debian/lenny/dependencies/tqca-tls/debian/tqca-tls.install   | 2 +-
 debian/squeeze/dependencies/tqca-tls/debian/control          | 1 +
 debian/squeeze/dependencies/tqca-tls/debian/rules            | 9 ++++++++-
 debian/squeeze/dependencies/tqca-tls/debian/tqca-tls.install | 2 +-
 6 files changed, 20 insertions(+), 4 deletions(-)

(limited to 'debian')

diff --git a/debian/lenny/dependencies/tqca-tls/debian/control b/debian/lenny/dependencies/tqca-tls/debian/control
index d84c1992b..8c719a019 100644
--- a/debian/lenny/dependencies/tqca-tls/debian/control
+++ b/debian/lenny/dependencies/tqca-tls/debian/control
@@ -8,6 +8,7 @@ Standards-Version: 3.8.4
 Package: tqca-tls
 Section: libs
 Architecture: any
+Multi-Arch: same
 Replaces: tqca-tls (<< 4:14.0.0~)
 Breaks: tqca-tls (<< 4:14.0.0~)
 Depends: ${shlibs:Depends}, ${misc:Depends}
diff --git a/debian/lenny/dependencies/tqca-tls/debian/rules b/debian/lenny/dependencies/tqca-tls/debian/rules
index 2ea43315e..22ec88d79 100755
--- a/debian/lenny/dependencies/tqca-tls/debian/rules
+++ b/debian/lenny/dependencies/tqca-tls/debian/rules
@@ -14,6 +14,7 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_MULTIARCH  ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 
 CFLAGS = -Wall -g
@@ -69,9 +70,15 @@ install: build
 	dh_clean -k
 	dh_installdirs
 
+	# update multi-arch path in install files
+	for a in debian/*install; do \
+	    [ -d $$a ] || [ -f $$a.arch ] || \
+	    sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+	done
+
 	# Add here commands to install the package into debian/tmp
 	$(MAKE) install INSTALL_ROOT=$(CURDIR)/debian/tmp/
-	[ -e $(CURDIR)/debian/tmp/usr/lib/tqt3/plugins/crypto/libtqca-tls.so ] || ( echo "libtqca-tls.so not in usr/lib/tqt3/plugins/crypto/libtqca-tls.so" && exit 1 )
+	[ -e $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/libtqca-tls.so ] || ( echo "libtqca-tls.so not in usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/libtqca-tls.so" && exit 1 )
 
 
 # Build architecture-independent files here.
diff --git a/debian/lenny/dependencies/tqca-tls/debian/tqca-tls.install b/debian/lenny/dependencies/tqca-tls/debian/tqca-tls.install
index d165ec389..bf57d3931 100644
--- a/debian/lenny/dependencies/tqca-tls/debian/tqca-tls.install
+++ b/debian/lenny/dependencies/tqca-tls/debian/tqca-tls.install
@@ -1 +1 @@
-usr/lib/tqt3/plugins/crypto/*
+usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/*
diff --git a/debian/squeeze/dependencies/tqca-tls/debian/control b/debian/squeeze/dependencies/tqca-tls/debian/control
index d84c1992b..8c719a019 100644
--- a/debian/squeeze/dependencies/tqca-tls/debian/control
+++ b/debian/squeeze/dependencies/tqca-tls/debian/control
@@ -8,6 +8,7 @@ Standards-Version: 3.8.4
 Package: tqca-tls
 Section: libs
 Architecture: any
+Multi-Arch: same
 Replaces: tqca-tls (<< 4:14.0.0~)
 Breaks: tqca-tls (<< 4:14.0.0~)
 Depends: ${shlibs:Depends}, ${misc:Depends}
diff --git a/debian/squeeze/dependencies/tqca-tls/debian/rules b/debian/squeeze/dependencies/tqca-tls/debian/rules
index 2ea43315e..22ec88d79 100755
--- a/debian/squeeze/dependencies/tqca-tls/debian/rules
+++ b/debian/squeeze/dependencies/tqca-tls/debian/rules
@@ -14,6 +14,7 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_MULTIARCH  ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 
 CFLAGS = -Wall -g
@@ -69,9 +70,15 @@ install: build
 	dh_clean -k
 	dh_installdirs
 
+	# update multi-arch path in install files
+	for a in debian/*install; do \
+	    [ -d $$a ] || [ -f $$a.arch ] || \
+	    sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+	done
+
 	# Add here commands to install the package into debian/tmp
 	$(MAKE) install INSTALL_ROOT=$(CURDIR)/debian/tmp/
-	[ -e $(CURDIR)/debian/tmp/usr/lib/tqt3/plugins/crypto/libtqca-tls.so ] || ( echo "libtqca-tls.so not in usr/lib/tqt3/plugins/crypto/libtqca-tls.so" && exit 1 )
+	[ -e $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/libtqca-tls.so ] || ( echo "libtqca-tls.so not in usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/libtqca-tls.so" && exit 1 )
 
 
 # Build architecture-independent files here.
diff --git a/debian/squeeze/dependencies/tqca-tls/debian/tqca-tls.install b/debian/squeeze/dependencies/tqca-tls/debian/tqca-tls.install
index d165ec389..bf57d3931 100644
--- a/debian/squeeze/dependencies/tqca-tls/debian/tqca-tls.install
+++ b/debian/squeeze/dependencies/tqca-tls/debian/tqca-tls.install
@@ -1 +1 @@
-usr/lib/tqt3/plugins/crypto/*
+usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins/crypto/*
-- 
cgit v1.2.1