From d6f47b905ee995b58fcb8388f683971ce9a2c7ed Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Fran=C3=A7ois=20Andriot?= <albator78@libertysurf.fr>
Date: Sun, 10 Mar 2019 20:22:48 +0100
Subject: RPM: switch many packages to cmake

---
 redhat/applications/knights/knights.spec | 167 +++++++++++++++++++++++++++++++
 1 file changed, 167 insertions(+)
 create mode 100644 redhat/applications/knights/knights.spec

(limited to 'redhat/applications/knights/knights.spec')

diff --git a/redhat/applications/knights/knights.spec b/redhat/applications/knights/knights.spec
new file mode 100644
index 000000000..a5df6282b
--- /dev/null
+++ b/redhat/applications/knights/knights.spec
@@ -0,0 +1,167 @@
+#
+# spec file for package knights (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.0
+%endif
+%define tde_pkg knights
+%define tde_prefix /opt/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name:		trinity-%{tde_pkg}
+Epoch:		%{tde_epoch}
+Version:	0.6
+Release:	%{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary:	A chess interface for the K Desktop Environment [Trinity]
+Group:		Amusements/Games
+URL:		http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License:	GPL-2.0+
+%else
+License:	GPLv2+
+%endif
+
+#Vendor:		Trinity Desktop
+#Packager:	Francois Andriot <francois.andriot@free.fr>
+
+Prefix:		%{tde_prefix}
+BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0:		%{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires:	trinity-tdelibs-devel >= %{tde_version}
+BuildRequires:	trinity-tdebase-devel >= %{tde_version}
+BuildRequires:	desktop-file-utils
+BuildRequires:	gettext
+
+BuildRequires:	cmake >= 2.8
+BuildRequires:	gcc-c++
+BuildRequires:	pkgconfig
+BuildRequires:	libtool
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires:	update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires:	brp-check-trinity
+%endif
+
+# GNUCHESS support
+Requires:		gnuchess
+
+%description
+Knights aims to be the ultimate chess resource on your computer. 
+Written for the K Desktop Environment, it's designed to be both friendly 
+to new chess players and functional for Grand Masters.
+
+Here's a quick list of Knights' key features:
+* Play against yourself, against computer opponents, 
+  or against others over the Internet.
+* Customize your board and pieces with over 30 different themes, 
+  or make your own!
+* Audio cues help alert you to important events.
+* Novice players can preview potential moves.
+* Save your unfinished matches and play them again later.
+
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+  %__mkdir_p build
+  cd build
+fi
+
+%cmake \
+  -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+  -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+  -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+  -DCMAKE_SKIP_RPATH=OFF \
+  -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+  -DCMAKE_VERBOSE_MAKEFILE=ON \
+  -DWITH_GCC_VISIBILITY=OFF \
+  \
+  -DCMAKE_INSTALL_PREFIX="%{tde_prefix}" \
+  -DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
+  -DLIB_INSTALL_DIR="%{tde_libdir}" \
+  \
+  -DWITH_ALL_OPTIONS=ON \
+  -DWITH_GCC_VISIBILITY=ON \
+  \
+  -DBUILD_ALL=ON \
+  -DBUILD_DOC=ON \
+  -DBUILD_TRANSLATIONS=ON \
+  ..
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
+
+%find_lang %{tde_pkg}
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%{tde_bindir}/knights
+%{tde_datadir}/applnk/Games/Board/knights.desktop
+%{tde_datadir}/apps/knights
+%{tde_tdedocdir}/HTML/*/knights
+%{tde_datadir}/icons/hicolor/*/*/*.png
+%{tde_datadir}/mimelnk/application/pgn.desktop
+%{tde_mandir}/man1/*.1*
+
+
+%changelog
-- 
cgit v1.2.1