From 7abdfa3a6ff766651598f0c4c1363c9a0f29860d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sl=C3=A1vek=20Banko?= <slavek.banko@axis.cz>
Date: Sun, 2 Jun 2019 04:16:45 +0200
Subject: DEB: Added support for using the $(DEB_HOST_MULTIARCH) variable in
 the install and links files to the debian-tde.mk common rules.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
---
 ubuntu/_base/applications/kbiff/debian/cdbs/debian-tde.mk | 10 ++++++++++
 1 file changed, 10 insertions(+)

(limited to 'ubuntu/_base/applications/kbiff/debian/cdbs')

diff --git a/ubuntu/_base/applications/kbiff/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/kbiff/debian/cdbs/debian-tde.mk
index fb8c1b6c3..7c67fc9ca 100644
--- a/ubuntu/_base/applications/kbiff/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/applications/kbiff/debian/cdbs/debian-tde.mk
@@ -140,12 +140,22 @@ common-binary-arch::
 	    cat $$tmpf >>debian/$$p.substvars; \
 	done; \
 	rm -f $$tmpf )
+	# update multi-arch path in install files
+	for a in debian/*install debian/*links; do \
+	    [ -d $$a ] || [ -f $$a.arch ] || \
+	    sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+	done
 
 clean::
 	rm -rf debian/man/out
 	-rmdir debian/man
 	rm -f debian/stamp-man-pages
 	rm -rf debian/shlibs-check
+	# revert multi-arch path in install files
+	for a in debian/*install debian/*links; do \
+	    [ ! -f $$a.arch ] || \
+	    mv $$a.arch $$a; \
+	done
 
 $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
 	if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-- 
cgit v1.2.1