From d6446b3057170457f9f201fe51e8c63b87dda09c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sl=C3=A1vek=20Banko?= <slavek.banko@axis.cz>
Date: Mon, 10 Aug 2020 23:59:11 +0200
Subject: DEB mathemagics: Add packaging files.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
---
 ubuntu/_base/applications/mathemagics/debian/rules | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100755 ubuntu/_base/applications/mathemagics/debian/rules

(limited to 'ubuntu/_base/applications/mathemagics/debian/rules')

diff --git a/ubuntu/_base/applications/mathemagics/debian/rules b/ubuntu/_base/applications/mathemagics/debian/rules
new file mode 100755
index 000000000..18aa16b96
--- /dev/null
+++ b/ubuntu/_base/applications/mathemagics/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+                               && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
-- 
cgit v1.2.1