From 3d0fe45a7b0b586d096644a3581df8307787eb3a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sl=C3=A1vek=20Banko?= <slavek.banko@axis.cz>
Date: Sun, 4 Apr 2021 03:02:11 +0200
Subject: DEB: Move DEB_DH_BUILDDEB_ARGS to common cdbs rules.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
---
 ubuntu/_base/applications/tdepacman/debian/cdbs/debian-tde.mk | 10 ++++++++++
 1 file changed, 10 insertions(+)

(limited to 'ubuntu/_base/applications/tdepacman/debian/cdbs')

diff --git a/ubuntu/_base/applications/tdepacman/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/tdepacman/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/ubuntu/_base/applications/tdepacman/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/applications/tdepacman/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
 DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
 DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
 
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+                         sed -e "s|.*version ||" -e "s| .*||" | \
+                         xargs -r dpkg --compare-versions 1.17.0 lt \
+                         && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+                               && echo xz || echo bzip2)
+endif
+
 ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
     cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
     ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
-- 
cgit v1.2.1