From 1b6efb141bcf333e5c73a520e701d1de8cafcf4e Mon Sep 17 00:00:00 2001
From: Timothy Pearson <kb9vqf@pearsoncomputing.net>
Date: Fri, 4 Nov 2011 12:06:08 -0500
Subject: Rename kde packages to tde

---
 .../maverick/tdepim/debian/cdbs/debian-qt-kde.mk   | 110 +++++++++++++++++++++
 1 file changed, 110 insertions(+)
 create mode 100644 ubuntu/maverick/tdepim/debian/cdbs/debian-qt-kde.mk

(limited to 'ubuntu/maverick/tdepim/debian/cdbs/debian-qt-kde.mk')

diff --git a/ubuntu/maverick/tdepim/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/tdepim/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..271a018a9
--- /dev/null
+++ b/ubuntu/maverick/tdepim/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,110 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+	touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+    ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+        cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+    else
+        cdbs_kde_enable_final =
+    endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+	if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+	for f in $$(find debian/man -name '*.sgml'); do \
+		docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+	done
+	for f in $$(find debian/man -name '*.man'); do \
+		soelim -I debian/man $$f \
+		> debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+	done
+	touch debian/stamp-man-pages
+
+common-binary-indep::
+	( set -e; \
+	tmpf=`mktemp debian/versions.XXXXXX`; \
+	perl debian/cdbs/versions.pl >$$tmpf; \
+	for p in $(DEB_INDEP_PACKAGES); do \
+	    cat $$tmpf >>debian/$$p.substvars; \
+	done; \
+	rm -f $$tmpf )
+
+common-binary-arch::
+	( set -e; \
+	tmpf=`mktemp debian/versions.XXXXXX`; \
+	perl debian/cdbs/versions.pl >$$tmpf; \
+	for p in $(DEB_ARCH_PACKAGES); do \
+	    cat $$tmpf >>debian/$$p.substvars; \
+	done; \
+	rm -f $$tmpf )
+
+clean::
+	rm -rf debian/man/out
+	-rmdir debian/man
+	rm -f debian/stamp-man-pages
+	rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+	if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+	if test -e debian/$(cdbs_curpkg).lintian; then \
+		install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+			debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+	fi
+	if test -e debian/$(cdbs_curpkg).presubj; then \
+		install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+			debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+	fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+	set -e; \
+	for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en; find . -name index.docbook`; do \
+		pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+		echo Building $$pkg HTML docs...; \
+		mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+		cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+		/opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en/$$pkg/index.docbook; \
+	done
+	for pkg in $(DOC_HTML_PRUNE) ; do \
+	  rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+	done
+
+clean::
+	rm -f debian/stamp-cvs-make
+
+endif
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+	$(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+	touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+	$(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+	rm -f debian/stamp-kde-apidox
-- 
cgit v1.2.1