From 02dc85a95b228b7242b0d11ea35619faad96db03 Mon Sep 17 00:00:00 2001
From: Timothy Pearson <kb9vqf@pearsoncomputing.net>
Date: Mon, 10 Sep 2012 16:16:32 -0500
Subject: Split precise from maverick

---
 ubuntu/precise/applications/kdpkg/debian/rules | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
 create mode 100755 ubuntu/precise/applications/kdpkg/debian/rules

(limited to 'ubuntu/precise/applications/kdpkg/debian/rules')

diff --git a/ubuntu/precise/applications/kdpkg/debian/rules b/ubuntu/precise/applications/kdpkg/debian/rules
new file mode 100755
index 000000000..b2822c5b3
--- /dev/null
+++ b/ubuntu/precise/applications/kdpkg/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+  
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+	! [ -f /usr/share/libtool/ltmain.sh ] || \
+	cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+	! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+	cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+	cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+	make -f admin/Makefile.common cvs
+	touch debian/stamp-bootstrap
-- 
cgit v1.2.1