summaryrefslogtreecommitdiffstats
path: root/style/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'style/Makefile.am')
-rw-r--r--style/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/style/Makefile.am b/style/Makefile.am
new file mode 100644
index 0000000..2094915
--- /dev/null
+++ b/style/Makefile.am
@@ -0,0 +1,16 @@
+AM_CPPFLAGS = -DQT_PLUGIN
+
+INCLUDES = -I$(top_srcdir)/kdefx $(all_includes)
+noinst_HEADERS = baghira.h pixmaps.h bitmaps.h
+METASOURCES = AUTO
+kde_style_LTLIBRARIES = baghira.la
+baghira_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+baghira_la_LIBADD = -lkdefx -lXtst $(LIB_KDEUI)
+baghira_la_SOURCES = baghira.cpp optionHandler.cpp polish.cpp utils.cpp
+lnkdir = $(kde_datadir)/kstyle/themes
+lnk_DATA = baghira.themerc
+EXTRA_DIST = $(lnk_DATA)
+pixmaps.h: $(srcdir)/generatePixmaps.sh
+ $(SHELL) $(srcdir)/generatePixmaps.sh $(top_srcdir)
+CLEANFILES = pixmaps.h
+baghira.lo: pixmaps.h