summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/desktop/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /kfile-plugins/desktop/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/desktop/Makefile.am')
-rw-r--r--kfile-plugins/desktop/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kfile-plugins/desktop/Makefile.am b/kfile-plugins/desktop/Makefile.am
new file mode 100644
index 0000000..4fdfa7f
--- /dev/null
+++ b/kfile-plugins/desktop/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for .desktop file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_desktop.h
+
+kde_module_LTLIBRARIES = kfile_desktop.la
+
+kfile_desktop_la_SOURCES = kfile_desktop.cpp
+kfile_desktop_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_desktop_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kfile_desktop.pot
+
+services_DATA = kfile_desktop.desktop
+servicesdir = $(kde_servicesdir)