summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/lyrics/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /noatun-plugins/lyrics/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'noatun-plugins/lyrics/Makefile.am')
-rw-r--r--noatun-plugins/lyrics/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/noatun-plugins/lyrics/Makefile.am b/noatun-plugins/lyrics/Makefile.am
new file mode 100644
index 0000000..ac34a17
--- /dev/null
+++ b/noatun-plugins/lyrics/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES= $(all_includes)
+kde_module_LTLIBRARIES = noatunlyrics.la
+
+noatunlyrics_la_SOURCES = lyrics.cpp historymanager.cpp cmodule.cpp
+
+noatunlyrics_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatunlyrics_la_LIBADD = $(LIB_KHTML) $(LIB_KFILE) -lnoatun
+
+noatunlyrics_la_METASOURCES = AUTO
+
+noinst_HEADERS = lyrics.h
+
+noatun_DATA = lyrics.plugin lyricsui.rc
+noatundir = $(kde_datadir)/noatun
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/lyrics.pot