summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/lnk/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-15 20:12:47 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-15 20:12:47 +0200
commitcb8cda7bca532df21c02bc4d2bfd03387df7f852 (patch)
tree7f6b988c304024c9a45bccc2070790b65b95553e /tdefile-plugins/lnk/CMakeLists.txt
parent41f27d91571102626d9aae843adbe070fcb5aef3 (diff)
downloadtdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.tar.gz
tdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdefile-plugins/lnk/CMakeLists.txt')
-rw-r--r--tdefile-plugins/lnk/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/tdefile-plugins/lnk/CMakeLists.txt b/tdefile-plugins/lnk/CMakeLists.txt
index 3636de5..d6a332f 100644
--- a/tdefile-plugins/lnk/CMakeLists.txt
+++ b/tdefile-plugins/lnk/CMakeLists.txt
@@ -33,14 +33,20 @@ tde_add_kpart( tdefile_lnk AUTOMOC
##### other data ################################
-install( FILES lnkforward.desktop
+tde_create_translated_desktop(
+ SOURCE lnkforward.desktop
DESTINATION ${APPS_INSTALL_DIR}/.hidden
+ PO_DIR tdefile-desktops
)
-install( FILES x-win-lnk.desktop
+tde_create_translated_desktop(
+ SOURCE x-win-lnk.desktop
DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR tdefile-desktops
)
-install( FILES tdefile_lnk.desktop
+tde_create_translated_desktop(
+ SOURCE tdefile_lnk.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdefile-desktops
)