summaryrefslogtreecommitdiffstats
path: root/kate/katesort/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kate/katesort/src/Makefile.am')
-rw-r--r--kate/katesort/src/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kate/katesort/src/Makefile.am b/kate/katesort/src/Makefile.am
new file mode 100644
index 0000000..b58b34a
--- /dev/null
+++ b/kate/katesort/src/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+KDE_ICON = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = libsortplugin.la
+
+libsortplugin_la_SOURCES = plugin_sort.cpp sortdialog.cpp sortdialoglayout.ui
+libsortplugin_la_LIBADD = -lkateinterfaces
+libsortplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_datadir)/kate/plugins/sort
+plugins_DATA = plugin_sort.rc
+
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/katesort.pot
+noinst_HEADERS = sortdialog.h sortdialoglayout.h
+kde_services_DATA = katesort.desktop