summaryrefslogtreecommitdiffstats
path: root/konq-plugins/arkplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'konq-plugins/arkplugin/CMakeLists.txt')
-rw-r--r--konq-plugins/arkplugin/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/konq-plugins/arkplugin/CMakeLists.txt b/konq-plugins/arkplugin/CMakeLists.txt
new file mode 100644
index 0000000..17a2091
--- /dev/null
+++ b/konq-plugins/arkplugin/CMakeLists.txt
@@ -0,0 +1,33 @@
+# This file is genereted by triniy-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### libarkplugin (kpart) ######################
+
+tde_add_kpart( libarkplugin AUTOMOC
+ SOURCES arkplugin.cpp
+ LINK konq-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES ark_plugin.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)
+
+install( FILES arkplugin.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden
+)