summaryrefslogtreecommitdiffstats
path: root/styles/dotnet/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-11 14:54:26 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-12 15:24:51 +0200
commitc6babe2180543ce656d7c517d6db047285295597 (patch)
tree90bf7fd65cc790d7ea5fb306fc9a6f5a56cc12c9 /styles/dotnet/CMakeLists.txt
parent95331e2c05fce1a8abe31b62f77a4f1d72ca1fd3 (diff)
downloadtdeartwork-c6babe2180543ce656d7c517d6db047285295597.tar.gz
tdeartwork-c6babe2180543ce656d7c517d6db047285295597.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 7c7c238be19c9d17b1182d0b0fad31479aa7f59a)
Diffstat (limited to 'styles/dotnet/CMakeLists.txt')
-rw-r--r--styles/dotnet/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/styles/dotnet/CMakeLists.txt b/styles/dotnet/CMakeLists.txt
index 15a2ef0f..824aff4c 100644
--- a/styles/dotnet/CMakeLists.txt
+++ b/styles/dotnet/CMakeLists.txt
@@ -25,7 +25,11 @@ link_directories(
##### other data ################################
-install( FILES dotnet.themerc DESTINATION ${DATA_INSTALL_DIR}/tdestyle/themes )
+tde_create_translated_desktop(
+ SOURCE dotnet.themerc
+ DESTINATION ${DATA_INSTALL_DIR}/tdestyle/themes
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/style-themes
+)
##### dotnet #####################################