summaryrefslogtreecommitdiffstats
path: root/ksplashml/themeengine/unified/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-09-14 20:11:45 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-09-14 20:11:45 +0000
commita382b3ab3160bc265983c538cb235eb51b87a4c5 (patch)
tree9805f2010c017b8376673c4f5f11aed8bcab310a /ksplashml/themeengine/unified/CMakeLists.txt
parent75ab9920ac2043f45a09dd50763e14f58de9cd65 (diff)
downloadtdebase-a382b3ab3160bc265983c538cb235eb51b87a4c5.tar.gz
tdebase-a382b3ab3160bc265983c538cb235eb51b87a4c5.zip
Add new "Unified" splash screen
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1253671 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksplashml/themeengine/unified/CMakeLists.txt')
-rw-r--r--ksplashml/themeengine/unified/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/ksplashml/themeengine/unified/CMakeLists.txt b/ksplashml/themeengine/unified/CMakeLists.txt
new file mode 100644
index 000000000..5200fb060
--- /dev/null
+++ b/ksplashml/themeengine/unified/CMakeLists.txt
@@ -0,0 +1,45 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ #${CMAKE_CURRENT_SOURCE_DIR}
+ #${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/ksplashml/themeengine
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES ksplashunified.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### ksplashunified (module) ###################
+
+tde_add_kpart( ksplashunified AUTOMOC
+ SOURCES main.cpp
+ LINK themeunified-static ksplashthemes-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### themeunified (static) #####################
+
+tde_add_library( themeunified STATIC_PIC AUTOMOC
+ SOURCES themeunified.cpp
+ LINK ksplashthemes-shared
+)