summaryrefslogtreecommitdiffstats
path: root/ksplashml/themeengine/unified/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-09-14 20:11:45 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-09-14 20:11:45 +0000
commita382b3ab3160bc265983c538cb235eb51b87a4c5 (patch)
tree9805f2010c017b8376673c4f5f11aed8bcab310a /ksplashml/themeengine/unified/Makefile.am
parent75ab9920ac2043f45a09dd50763e14f58de9cd65 (diff)
downloadtdebase-a382b3ab3160bc265983c538cb235eb51b87a4c5.tar.gz
tdebase-a382b3ab3160bc265983c538cb235eb51b87a4c5.zip
Add new "Unified" splash screen
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1253671 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksplashml/themeengine/unified/Makefile.am')
-rw-r--r--ksplashml/themeengine/unified/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/ksplashml/themeengine/unified/Makefile.am b/ksplashml/themeengine/unified/Makefile.am
new file mode 100644
index 000000000..e3f522751
--- /dev/null
+++ b/ksplashml/themeengine/unified/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/../.. $(all_includes)
+
+noinst_LTLIBRARIES = libthemedefault.la
+libthemedefault_la_SOURCES = themelegacy.cpp
+libthemedefault_la_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+libthemedefault_la_LIBADD = $(LIB_KDEUI) ../libksplashthemes.la
+
+kde_module_LTLIBRARIES = ksplashdefault.la
+
+ksplashdefault_la_SOURCES = main.cpp
+ksplashdefault_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(KDE_PLUGIN) -module
+ksplashdefault_la_LIBADD = $(LIB_KDEUI) ../libksplashthemes.la libthemedefault.la
+METASOURCES = AUTO
+
+servicesdir = $(kde_servicesdir)
+services_DATA = ksplashdefault.desktop