summaryrefslogtreecommitdiffstats
path: root/l10n/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /l10n/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'l10n/CMakeLists.txt')
-rw-r--r--l10n/CMakeLists.txt26
1 files changed, 18 insertions, 8 deletions
diff --git a/l10n/CMakeLists.txt b/l10n/CMakeLists.txt
index c9516b52c..96c9eb5b5 100644
--- a/l10n/CMakeLists.txt
+++ b/l10n/CMakeLists.txt
@@ -7,7 +7,8 @@
#
#################################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
northafrica.desktop westafrica.desktop southafrica.desktop
centralafrica.desktop caribbean.desktop oceania.desktop
centralamerica.desktop northamerica.desktop southamerica.desktop
@@ -15,16 +16,25 @@ install( FILES
northeurope.desktop southeurope.desktop southasia.desktop
southeastasia.desktop eastasia.desktop centralasia.desktop
middleeast.desktop
- DESTINATION
- ${LOCALE_INSTALL_DIR}/l10n )
+ DESTINATION ${LOCALE_INSTALL_DIR}/l10n
+ PO_DIR l10n-desktops
+)
file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
foreach( _dir ${_dirs} )
- if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} )
- if( NOT (${_dir} STREQUAL ".svn" OR ${_dir} STREQUAL "CMakeFiles") )
- install( FILES ${_dir}/entry.desktop ${_dir}/flag.png
- DESTINATION ${LOCALE_INSTALL_DIR}/l10n/${_dir} )
- endif( )
+ if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} AND
+ NOT (${_dir} STREQUAL ".svn" OR ${_dir} STREQUAL "CMakeFiles") AND
+ EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}/entry.desktop AND
+ EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}/flag.png )
+ tde_create_translated_desktop(
+ SOURCE ${_dir}/entry.desktop
+ DESTINATION ${LOCALE_INSTALL_DIR}/l10n/${_dir}
+ PO_DIR l10n-desktops
+ )
+ install(
+ FILES ${_dir}/flag.png
+ DESTINATION ${LOCALE_INSTALL_DIR}/l10n/${_dir}
+ )
endif( )
endforeach( )