summaryrefslogtreecommitdiffstats
path: root/twin/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /twin/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'twin/CMakeLists.txt')
-rw-r--r--twin/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/twin/CMakeLists.txt b/twin/CMakeLists.txt
index 7b4badc6c..33a2302e4 100644
--- a/twin/CMakeLists.txt
+++ b/twin/CMakeLists.txt
@@ -43,7 +43,13 @@ install( FILES KWinInterface.h DESTINATION ${INCLUDE_INSTALL_DIR} )
##### other data ################################
tde_install_icons( twin )
-install( FILES eventsrc DESTINATION ${DATA_INSTALL_DIR}/twin )
+
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/twin
+ PO_DIR twin-eventsrc
+)
+
install( FILES twin.kcfg DESTINATION ${KCFG_INSTALL_DIR} )