summaryrefslogtreecommitdiffstats
path: root/twin/data/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /twin/data/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'twin/data/CMakeLists.txt')
-rw-r--r--twin/data/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/twin/data/CMakeLists.txt b/twin/data/CMakeLists.txt
index 9a0ce88da..840c5afcf 100644
--- a/twin/data/CMakeLists.txt
+++ b/twin/data/CMakeLists.txt
@@ -35,9 +35,11 @@ install( FILES
pop.wav
DESTINATION ${SOUND_INSTALL_DIR} )
-install( FILES
- fsp_workarounds_1.twinrules
- DESTINATION ${DATA_INSTALL_DIR}/twin/default_rules )
+tde_create_translated_desktop(
+ SOURCE fsp_workarounds_1.twinrules
+ DESTINATION ${DATA_INSTALL_DIR}/twin/default_rules
+ PO_DIR twin-desktops
+)
##### twin_update_window_settings (executable) ##