From 92841ae8b62560f0b137dc838bfd12ac78d26599 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sl=C3=A1vek=20Banko?= <slavek.banko@axis.cz>
Date: Sun, 28 Jun 2020 00:42:21 +0200
Subject: Desktop file translations: + Creation of POT template for desktop
 files added to CMakeL10n rules. + Added creation of translated desktop files
 during build.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
(cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
---
 kdesktop/kwebdesktop/CMakeLists.txt | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

(limited to 'kdesktop/kwebdesktop/CMakeLists.txt')

diff --git a/kdesktop/kwebdesktop/CMakeLists.txt b/kdesktop/kwebdesktop/CMakeLists.txt
index 741b8df34..34b84dc11 100644
--- a/kdesktop/kwebdesktop/CMakeLists.txt
+++ b/kdesktop/kwebdesktop/CMakeLists.txt
@@ -23,7 +23,11 @@ link_directories(
 
 ##### other data ################################
 
-install( FILES kwebdesktop.desktop DESTINATION ${DATA_INSTALL_DIR}/kdesktop/programs )
+tde_create_translated_desktop(
+  SOURCE kwebdesktop.desktop
+  DESTINATION ${DATA_INSTALL_DIR}/kdesktop/programs
+  PO_DIR kdesktop-desktops
+)
 install( FILES kwebdesktop.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
 
 
-- 
cgit v1.2.1