summaryrefslogtreecommitdiffstats
path: root/src/libtdebluez/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libtdebluez/CMakeLists.txt')
-rw-r--r--src/libtdebluez/CMakeLists.txt21
1 files changed, 6 insertions, 15 deletions
diff --git a/src/libtdebluez/CMakeLists.txt b/src/libtdebluez/CMakeLists.txt
index af33393..9c040d4 100644
--- a/src/libtdebluez/CMakeLists.txt
+++ b/src/libtdebluez/CMakeLists.txt
@@ -12,19 +12,6 @@
project( libtdebluez )
set(LIBRARY_VERSION 0.0.1)
-# include( ConfigureChecks.cmake )
-foreach( f ${TQT_LIBRARIES} )
- if( ${f} STREQUAL "tqt-mt" )
- set(TQUI_LIBRARIES "tqui" CACHE TYPE STRING FORCE)
- endif()
- if( ${f} STREQUAL "qt-mt" )
- set(TQUI_LIBRARIES "qui" CACHE TYPE STRING FORCE)
- endif()
-endforeach()
-
-# import required
-#tde_import( lib... )
-
add_subdirectory( interfaces )
include_directories(
@@ -42,8 +29,10 @@ link_directories(
${DBUS_TQT_LIBRARY_DIRS}
)
+
##### headers ###################################
# implementations
+
install(
FILES adapterImpl.h
btuuids.h
@@ -84,14 +73,16 @@ set( ${target}_SRCS
)
##### tdebluez (shared) ###########################
-# set( KDE3_DCOPIDL_EXECUTABLE ${KDE3_DCOPIDLNG_EXECUTABLE} )
+
tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION ${LIBRARY_VERSION}
DEPENDS bluezinterfaces-static
- LINK ${DBUS_TQT_LIBRARIES} tdeparts-shared bluezinterfaces-static ${TQUI_LIBRARIES}
+ LINK ${DBUS_TQT_LIBRARIES} tdeparts-shared bluezinterfaces-static ${TQTQUI_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)
+
##### install import cmake modules ###############
+
tde_install_export( )