summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-03-26 17:44:12 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-03-26 17:44:12 +0100
commit345e5527fa12e750b0ba4d6a9f100ce49c2b8038 (patch)
tree9a6d21f7d24d9b9d57c65f643bad364b2b297404 /translations/messages/CMakeLists.txt
parent64509425b39b988f3d9436b5c4482db8c86cf310 (diff)
downloadtdedocker-345e5527fa12e750b0ba4d6a9f100ce49c2b8038.tar.gz
tdedocker-345e5527fa12e750b0ba4d6a9f100ce49c2b8038.zip
Move translations to a new directory layout.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )