summaryrefslogtreecommitdiffstats
path: root/applnk/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-27 03:12:08 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-28 17:53:20 +0200
commit503dc8df8bab9ec5383b08abf6c94938f4aae4ed (patch)
treeb29093bede6ac30d0804a2bd1a53e60d0379963b /applnk/CMakeLists.txt
parentd802e99b97d5de62b978b343b0db7db52c212adc (diff)
downloadtdeedu-503dc8df8bab9ec5383b08abf6c94938f4aae4ed.tar.gz
tdeedu-503dc8df8bab9ec5383b08abf6c94938f4aae4ed.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a084db175509b58e57a81d50b1688709f19758bf)
Diffstat (limited to 'applnk/CMakeLists.txt')
-rw-r--r--applnk/CMakeLists.txt35
1 files changed, 20 insertions, 15 deletions
diff --git a/applnk/CMakeLists.txt b/applnk/CMakeLists.txt
index 86b65c6a..8b64a5a1 100644
--- a/applnk/CMakeLists.txt
+++ b/applnk/CMakeLists.txt
@@ -1,31 +1,36 @@
##### desktop files
-install(
- FILES languages.desktop
+tde_create_translated_desktop(
+ SOURCE languages.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Languages
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES mathematics.desktop
+tde_create_translated_desktop(
+ SOURCE mathematics.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Mathematics
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES science.desktop
+tde_create_translated_desktop(
+ SOURCE science.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Science
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES tools.desktop
+tde_create_translated_desktop(
+ SOURCE tools.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Tools
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES miscellaneous.desktop
+tde_create_translated_desktop(
+ SOURCE miscellaneous.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Miscellaneous
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)