summaryrefslogtreecommitdiffstats
path: root/applnk/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-27 16:35:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-06-28 13:45:47 +0200
commitaca01d5a8b7d3de53fa34696e18c91db720a5ab6 (patch)
tree6b9b83c599cc5db58df8041ca5cf812e00bbd25e /applnk/CMakeLists.txt
parent88af19c041ad4f1139f6f0a35cd1a4fe2018425f (diff)
downloadtdeedu-aca01d5a8b7d3de53fa34696e18c91db720a5ab6.tar.gz
tdeedu-aca01d5a8b7d3de53fa34696e18c91db720a5ab6.zip
Conversion to the cmake building system.
Add includes to UI files to resolve FTBFS. Signed-off-by: gregory guy <g-gregory@gmx.fr> Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit d4a1613e9f119ae68c695ab60f8d9856d1a54a52)
Diffstat (limited to 'applnk/CMakeLists.txt')
-rw-r--r--applnk/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/applnk/CMakeLists.txt b/applnk/CMakeLists.txt
new file mode 100644
index 00000000..86b65c6a
--- /dev/null
+++ b/applnk/CMakeLists.txt
@@ -0,0 +1,31 @@
+##### desktop files
+
+install(
+ FILES languages.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Languages
+ RENAME .directory
+)
+
+install(
+ FILES mathematics.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Mathematics
+ RENAME .directory
+)
+
+install(
+ FILES science.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Science
+ RENAME .directory
+)
+
+install(
+ FILES tools.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Tools
+ RENAME .directory
+)
+
+install(
+ FILES miscellaneous.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Miscellaneous
+ RENAME .directory
+)