summaryrefslogtreecommitdiffstats
path: root/kgeography/src/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce599e4f9f94b4eb00c1b5edb85bce5431ab3df2 (patch)
treed3bb9f5d25a2dc09ca81adecf39621d871534297 /kgeography/src/Makefile.am
downloadtdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.tar.gz
tdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeedu@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kgeography/src/Makefile.am')
-rw-r--r--kgeography/src/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/kgeography/src/Makefile.am b/kgeography/src/Makefile.am
new file mode 100644
index 00000000..e70ac19c
--- /dev/null
+++ b/kgeography/src/Makefile.am
@@ -0,0 +1,43 @@
+## Makefile.am for kgeography
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kgeography
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# the library search path.
+kgeography_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+# the libraries to link against.
+kgeography_LDADD = $(LIB_KDEUI)
+
+# which sources should be compiled for kgeography
+kgeography_SOURCES = main.cpp mapwidget.cpp division.cpp map.cpp mapparser.cpp kgeography.cpp mapchooser.cpp mypopup.cpp popupmanager.cpp settings.kcfgc flagdivisionasker.cpp askwidget.cpp mapasker.cpp capitaldivisionasker.cpp divisioncapitalasker.cpp boxasker.cpp divisionflagasker.cpp answer.cpp answersdialog.cpp
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kgeography.pot
+
+# this is where the kdelnk file will go
+xdg_apps_DATA = kgeography.desktop
+
+kde_kcfg_DATA = kgeography.kcfg
+
+# this is where the XML-GUI resource file goes
+rcdir = $(kde_datadir)/kgeography
+rc_DATA = kgeographyui.rc
+
+debug: kgeography
+ ddd ./kgeography
+
+valgrind: kgeography
+ valgrind --tool=memcheck --leak-check=yes ./kgeography
+
+noinst_PROGRAMS = script
+script_SOURCES = script.cpp
+script_LDADD = $(LIB_QT)
+script_LDFLAGS = $(all_libraries)