summaryrefslogtreecommitdiffstats
path: root/kig/kfile/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce599e4f9f94b4eb00c1b5edb85bce5431ab3df2 (patch)
treed3bb9f5d25a2dc09ca81adecf39621d871534297 /kig/kfile/Makefile.am
downloadtdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.tar.gz
tdeedu-ce599e4f9f94b4eb00c1b5edb85bce5431ab3df2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeedu@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kig/kfile/Makefile.am')
-rw-r--r--kig/kfile/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/kig/kfile/Makefile.am b/kig/kfile/Makefile.am
new file mode 100644
index 00000000..b8de2d3d
--- /dev/null
+++ b/kig/kfile/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = $(all_includes)
+
+noinst_HEADERS = \
+ kfile_drgeo.h \
+ kfile_kig.h
+
+kde_module_LTLIBRARIES = \
+ kfile_drgeo.la \
+ kfile_kig.la
+
+kfile_drgeo_la_SOURCES = kfile_drgeo.cpp
+kfile_drgeo_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_drgeo_la_LIBADD = $(LIB_KIO)
+
+kfile_kig_la_SOURCES = kfile_kig.cpp
+kfile_kig_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_kig_la_LIBADD = $(LIB_KIO)
+
+METASOURCES = AUTO
+
+services_DATA = \
+ kfile_drgeo.desktop \
+ kfile_kig.desktop
+servicesdir = $(kde_servicesdir)