summaryrefslogtreecommitdiffstats
path: root/ksnake/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitc90c389a8a8d9d8661e9772ec4144c5cf2039f23 (patch)
tree6d8391395bce9eaea4ad78958617edb20c6a7573 /ksnake/Makefile.am
downloadtdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.tar.gz
tdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegames@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ksnake/Makefile.am')
-rw-r--r--ksnake/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/ksnake/Makefile.am b/ksnake/Makefile.am
new file mode 100644
index 00000000..b46794a6
--- /dev/null
+++ b/ksnake/Makefile.am
@@ -0,0 +1,34 @@
+
+INCLUDES = -I$(top_srcdir)/libkdegames -I$(top_srcdir)/libkdegames/highscore/ $(all_includes)
+
+noinst_HEADERS = game.h rattler.h board.h bitmaps.h \
+ level.h ball.h snake.h basket.h startroom.h \
+ pixServer.h progress.h levels.h view.h version.h
+
+ksnake_SOURCES = game.cpp rattler.cpp board.cpp level.cpp ball.cpp \
+ snake.cpp basket.cpp startroom.cpp \
+ pixServer.cpp progress.cpp levels.cpp\
+ view.cpp main.cpp settings.kcfgc appearance.ui general.ui
+
+ksnake_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+ksnake_LDADD = $(LIB_KDEUI) $(LIB_KDEGAMES) -lm
+ksnake_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+METASOURCES = AUTO
+
+bin_PROGRAMS = ksnake
+
+######### build rules ################
+
+xdg_apps_DATA = ksnake.desktop
+kde_kcfg_DATA = ksnake.kcfg
+
+KDE_ICON = ksnake
+
+SUBDIRS = data
+
+rcdir = $(kde_datadir)/ksnake
+rc_DATA = ksnakeui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/ksnake.pot