summaryrefslogtreecommitdiffstats
path: root/kue/modules/freeplay/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kue/modules/freeplay/CMakeLists.txt')
-rw-r--r--kue/modules/freeplay/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kue/modules/freeplay/CMakeLists.txt b/kue/modules/freeplay/CMakeLists.txt
new file mode 100644
index 00000000..0f935a3c
--- /dev/null
+++ b/kue/modules/freeplay/CMakeLists.txt
@@ -0,0 +1,42 @@
+################################################################################
+# Improvements and feedback are welcome! #
+# This software is licensed under the terms of the GNU GPL v3 license. #
+################################################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+### kuefreeplay (library) #######################################################
+tde_add_library(
+ kuefreeplay SHARED AUTOMOC
+
+ SOURCES
+ freeplay.cpp
+
+ LINK
+ tdeio-shared
+ kue-shared
+
+ DESTINATION
+ ${LIB_INSTALL_DIR}
+)
+
+### data #######################################################################
+install(
+ FILES
+ freeplay.plugin
+
+ DESTINATION
+ ${DATA_INSTALL_DIR}/kue
+)
+
+# kate: replace-tabs true; tab-width 2; \ No newline at end of file