summaryrefslogtreecommitdiffstats
path: root/libtdegames/kgame/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libtdegames/kgame/Makefile.am')
-rw-r--r--libtdegames/kgame/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/libtdegames/kgame/Makefile.am b/libtdegames/kgame/Makefile.am
new file mode 100644
index 00000000..f49bc653
--- /dev/null
+++ b/libtdegames/kgame/Makefile.am
@@ -0,0 +1,29 @@
+
+noinst_LTLIBRARIES = libkgame.la
+
+# compile-order doesn't matter here but maybe we will split these section soon
+
+KGAME = kgame.cpp kplayer.cpp kgamenetwork.cpp kgameproperty.cpp \
+ kgamemessage.cpp kgameio.cpp kgameprocess.cpp kgamechat.cpp \
+ kgamepropertyhandler.cpp kgameerror.cpp kgamesequence.cpp
+KGAME_H = kgame.h kplayer.h kgamenetwork.h kgameproperty.h kgamemessage.h \
+ kgameio.h kgameprocess.h kgamepropertyarray.h \
+ kgamepropertylist.h kgamechat.h kgamepropertyhandler.h \
+ kgameerror.h kgamesequence.h kgameversion.h
+
+KMESSAGE = kmessageio.cpp kmessageserver.cpp kmessageclient.cpp
+KMESSAGE_H = kmessageio.h kmessageserver.h kmessageclient.h
+
+libkgameincludedir=$(includedir)/kgame
+libkgame_la_SOURCES = $(KMESSAGE) $(KGAME)
+
+libkgameinclude_HEADERS = $(KMESSAGE_H) $(KGAME_H)
+
+INCLUDES = -I$(top_srcdir)/libtdegames $(all_includes)
+METASOURCES = AUTO
+
+SUBDIRS = . dialogs
+
+messages:
+# $(XGETTEXT) `find . -name \*.h -o -name \*.cpp -o -name \*.cc` -o $(podir)/libtdegames.pot
+