summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-01-05 15:47:14 +0100
committerSlávek Banko <slavek.banko@axis.cz>2013-01-05 15:51:35 +0100
commit10db7e7cfc2be1be783ed6aa44514aea547b6768 (patch)
tree808fc52c451a0ccb0a3b5bfc87854dc1a8e51a91 /CMakeLists.txt
parent7f07ae0885d21091d9c018e84e6088a46639697d (diff)
downloadtdegraphics-10db7e7cfc2be1be783ed6aa44514aea547b6768.tar.gz
tdegraphics-10db7e7cfc2be1be783ed6aa44514aea547b6768.zip
Fix cmake build: kghostview parallel build
This resolves Bug 1301 (cherry picked from commit 923dc5953a93b0db1ba723a4cff040150dabfaaf)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18bb538d..2d345b43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,7 +95,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### kdegraphics directories ###################
-if( BUILD_KFILE_PLUGINS OR BUILD_GHOSTKVIEW )
+# kfile-plugins/ps requires dscparse-static library
+if( BUILD_KFILE_PLUGINS AND NOT BUILD_KGHOSTVIEW )
add_subdirectory( kghostview/dscparse )
endif( )