summaryrefslogtreecommitdiffstats
path: root/interfaces/kscript/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /interfaces/kscript/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'interfaces/kscript/Makefile.am')
-rw-r--r--interfaces/kscript/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/interfaces/kscript/Makefile.am b/interfaces/kscript/Makefile.am
new file mode 100644
index 000000000..a84d73863
--- /dev/null
+++ b/interfaces/kscript/Makefile.am
@@ -0,0 +1,21 @@
+SUBDIRS = . sample
+
+INCLUDES = -I$(top_srcdir)/kio -I$(top_srcdir) -I$(srcdir) -I$(srcdir)/.. $(all_includes)
+
+#lib_LTLIBRARIES = libkscriptloader.la libkscript.la
+lib_LTLIBRARIES = libkscript.la
+#libkscriptloader_la_SOURCES = scriptloader.cpp
+#libkscriptloader_la_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+#libkscriptloader_la_LIBADD = $(LIB_KPARTS)
+
+libkscript_la_SOURCES = scriptmanager.cpp
+libkscript_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -no-undefined
+libkscript_la_LIBADD = $(LIB_KIO)
+
+kscriptinclude_HEADERS = scriptinterface.h scriptclientinterface.h scriptmanager.h
+kscriptincludedir = $(includedir)
+
+METASOURCES = AUTO
+
+servicetypedir = $(kde_servicetypesdir)
+servicetype_DATA = scriptinterface.desktop