summaryrefslogtreecommitdiffstats
path: root/kjs/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-08-17 22:26:29 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-08-18 23:02:35 +0900
commit3ccc8ad970ccf6e4c5e2abef212af44e17eb0fca (patch)
treeca31ef78594141e9a4c66cbfaac42d9a69ab8033 /kjs/Makefile.am
parent8b5a45212267b1730a3b59a32067ec088216c725 (diff)
downloadtdelibs-3ccc8ad970ccf6e4c5e2abef212af44e17eb0fca.tar.gz
tdelibs-3ccc8ad970ccf6e4c5e2abef212af44e17eb0fca.zip
kjs: use libpcre2 instead of libpcre
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 7740e825a683a9cc84f8422c94109c5fcc4beb8e)
Diffstat (limited to 'kjs/Makefile.am')
-rw-r--r--kjs/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/kjs/Makefile.am b/kjs/Makefile.am
index 89f937906..8dc05f656 100644
--- a/kjs/Makefile.am
+++ b/kjs/Makefile.am
@@ -17,7 +17,7 @@
# Boston, MA 02110-1301, USA.
YACC = bison
-INCLUDES = $(PCRECFLAGS) $(all_includes)
+INCLUDES = $(PCRE2CFLAGS) $(all_includes)
lib_LTLIBRARIES = libkjs.la
@@ -50,7 +50,7 @@ endif
libkjs_la_LDFLAGS = -version-info 3:0:2 -no-undefined $(VSCRIPT) \
$(USER_LDFLAGS) $(all_libraries)
-libkjs_la_LIBADD = -lm $(LIBPCRE)
+libkjs_la_LIBADD = -lm $(LIBPCRE2)
EXTRA_DIST = grammar.y
@@ -93,7 +93,7 @@ CLEANFILES = $(LUT_FILES)
## test program (in one program for easier profiling/memory debugging)
EXTRA_PROGRAMS = testkjs_static
testkjs_static_SOURCES = testkjs.cpp
-testkjs_static_LDADD = $(LIBPCRE) libkjs.la
+testkjs_static_LDADD = $(LIBPCRE2) libkjs.la
testkjs_static_LDFLAGS = -static
## test program (linked to libkjs)