summaryrefslogtreecommitdiffstats
path: root/tdecert/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /tdecert/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'tdecert/CMakeLists.txt')
-rw-r--r--tdecert/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tdecert/CMakeLists.txt b/tdecert/CMakeLists.txt
index 2a9c391e3..75f354c99 100644
--- a/tdecert/CMakeLists.txt
+++ b/tdecert/CMakeLists.txt
@@ -31,7 +31,11 @@ link_directories(
##### other data ################################
-install( FILES tdecertpart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdecertpart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)
+
install( FILES tdecertpart.rc DESTINATION ${DATA_INSTALL_DIR}/tdecertpart )