summaryrefslogtreecommitdiffstats
path: root/tdeioslave/ftp/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeioslave/ftp/Makefile.am
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/ftp/Makefile.am')
-rw-r--r--tdeioslave/ftp/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tdeioslave/ftp/Makefile.am b/tdeioslave/ftp/Makefile.am
new file mode 100644
index 000000000..c062d6430
--- /dev/null
+++ b/tdeioslave/ftp/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES= $(all_includes)
+
+####### Files
+
+kde_module_LTLIBRARIES = kio_ftp.la
+
+kio_ftp_la_SOURCES = ftp.cc
+kio_ftp_la_LIBADD = $(LIB_KIO) $(LIB_QT) $(LIB_TDECORE)
+kio_ftp_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+noinst_HEADERS = ftp.h
+
+kdelnk_DATA = ftp.protocol
+kdelnkdir = $(kde_servicesdir)
+
+