summaryrefslogtreecommitdiffstats
path: root/tdeutils/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /tdeutils/CMakeLists.txt
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'tdeutils/CMakeLists.txt')
-rw-r--r--tdeutils/CMakeLists.txt66
1 files changed, 66 insertions, 0 deletions
diff --git a/tdeutils/CMakeLists.txt b/tdeutils/CMakeLists.txt
new file mode 100644
index 000000000..1e1982da4
--- /dev/null
+++ b/tdeutils/CMakeLists.txt
@@ -0,0 +1,66 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( ksettings )
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeui
+ ${CMAKE_SOURCE_DIR}/tdeio/tdeio
+ ${CMAKE_SOURCE_DIR}/tdeutils
+ ${CMAKE_SOURCE_DIR}/interfaces/kregexpeditor
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ kfind.h kfinddialog.h kreplace.h kreplacedialog.h
+ tdecmoduleinfo.h tdecmoduleloader.h kcmultidialog.h
+ tdemultitabbar.h kplugininfo.h tdecmoduleproxy.h
+ kpluginselector.h tdecmodulecontainer.h
+ DESTINATION ${INCLUDE_INSTALL_DIR} )
+
+
+##### other data ################################
+
+install( FILES kplugininfo.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+
+#### tdeutils #####################################
+
+set( target tdeutils )
+
+set( ${target}_SRCS
+ kfind.cpp kfinddialog.cpp kreplace.cpp
+ kreplacedialog.cpp tdecmoduleinfo.cpp tdecmoduleloader.cpp
+ kcmultidialog.cpp tdemultitabbar.cpp kplugininfo.cpp
+ tdecmoduleproxy.cpp kpluginselector.cpp tdecmodulecontainer.cpp
+ tdecmoduleproxyIface.skel tdecmoduleproxyIfaceImpl.cpp
+)
+
+tde_add_library( ${target} SHARED AUTOMOC
+ SOURCES ${${target}_SRCS}
+ VERSION 1.2.0
+ EMBED ksettings-static
+ LINK tdeparts-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+ DEPENDENCIES dcopidl
+)