summaryrefslogtreecommitdiffstats
path: root/tdeutils/Makefile.am
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /tdeutils/Makefile.am
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'tdeutils/Makefile.am')
-rw-r--r--tdeutils/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tdeutils/Makefile.am b/tdeutils/Makefile.am
new file mode 100644
index 000000000..b8ae57de2
--- /dev/null
+++ b/tdeutils/Makefile.am
@@ -0,0 +1,31 @@
+SUBDIRS = ksettings .
+INCLUDES = -I$(top_srcdir)/interfaces/kregexpeditor $(all_includes)
+
+lib_LTLIBRARIES = libtdeutils.la
+libtdeutils_la_LDFLAGS = $(all_libraries) -no-undefined -version-info 3:0:2
+# Needs TDETrader
+libtdeutils_la_LIBADD = ../tdeio/libtdeio.la ksettings/libksettings.la $(LIB_QT) $(top_builddir)/dcop/libDCOP.la $(LIB_TDEUI) $(LIB_TDECORE) $(LIB_X11)
+
+libtdeutils_la_SOURCES = kfind.cpp kfinddialog.cpp kreplace.cpp \
+ kreplacedialog.cpp tdecmoduleinfo.cpp tdecmoduleloader.cpp \
+ kcmultidialog.cpp tdemultitabbar.cpp kplugininfo.cpp \
+ tdecmoduleproxy.cpp kpluginselector.cpp \
+ tdecmodulecontainer.cpp tdecmoduleproxyIface.skel \
+ tdecmoduleproxyIfaceImpl.cpp
+
+include_HEADERS = kfind.h kfinddialog.h kreplace.h kreplacedialog.h \
+ tdecmoduleinfo.h tdecmoduleloader.h kcmultidialog.h \
+ tdemultitabbar.h kplugininfo.h tdecmoduleproxy.h \
+ kpluginselector.h tdecmodulecontainer.h
+
+noinst_HEADERS = tdemultitabbar_p.h kpluginselector_p.h \
+ tdecmoduleproxyIface.h tdecmoduleproxyIfaceImpl.h
+
+kde_servicetypes_DATA = kplugininfo.desktop
+
+METASOURCES = AUTO
+
+DOXYGEN_REFERENCES = tdecore tdeui kio
+include ../admin/Doxyfile.am
+
+# vim: et