summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d6f11106..1628a580d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -854,7 +854,10 @@ set( HAVE_LIBPNG 1 )
##### check for tiff ############################
if( WITH_TIFF )
- find_package( TIFF )
+ pkg_search_module( TIFF libtiff-4 )
+ if( NOT TIFF_FOUND )
+ find_package( TIFF )
+ endif( NOT TIFF_FOUND )
if( NOT TIFF_FOUND )
message(FATAL_ERROR "\ntiff are requested, but not found on your system" )
endif( NOT TIFF_FOUND )