summaryrefslogtreecommitdiffstats
path: root/kdemm/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdemm/test/Makefile.am')
-rw-r--r--kdemm/test/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/kdemm/test/Makefile.am b/kdemm/test/Makefile.am
new file mode 100644
index 000000000..d488da365
--- /dev/null
+++ b/kdemm/test/Makefile.am
@@ -0,0 +1,30 @@
+# This file is part of the KDE libraries
+# Copyright (C) 2004 Matthias Kretz <kretz@kde.org>
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License version 2 as published by the Free Software Foundation.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public License
+# along with this library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+
+INCLUDES = -I$(top_srcdir)/kdemm $(all_includes)
+
+METASOURCES = AUTO
+
+check_PROGRAMS = guitest statetest
+
+guitest_SOURCES = main.cpp testwidget.cpp
+guitest_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+guitest_LDADD = $(LIB_KPARTS) $(top_builddir)/kdemm/libkdemm.la
+
+statetest_SOURCES = statetest.cpp
+statetest_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+statetest_LDADD = $(top_builddir)/kdemm/libkdemm.la